Dear user, Pocket Geek ID is currently only compatible with Firefox and Chrome.

Please use Firefox (version 57+) or Chrome (version 66+) to start your Pocket Geek ID download. Do not hesitate to contact us if you are experiencing any issues during the installation process.

Don’t have Firefox or Chrome on your computer yet? Click below to download.

Chrome Install Chrome Firefox Install Firefox